1. Написать программу для решения задачи: Точки ** плоскости заданы своими координатами....

0 голосов
37 просмотров
1.
Написать
программу для решения задачи: Точки на плоскости
заданы своими координатами. Определить какая из них находится ближе к началу
координат.






Информатика (54 баллов) | 37 просмотров
0

начало координат вводить? На каком языке?

0

А?

0

да вводить, Pascal

0

ок

0

а кол-во точек?

0

3 наверное

0

или вводить?

0

ввести нужно

Дан 1 ответ
0 голосов

Uses crt;
var n,minind,i:integer;
min,x,y:real;
begin
writeln('Введите количество точек: ');
read(n);
writeln('Вводите по очереди координаты x и y точек.');
read(x,y);
min:=sqr(x)+sqr(y);
minind:=1;
for i:=2 to n do
begin
read(x,y);
if sqr(x)+sqr(y)begin
min:=sqr(x)+sqr(y);
minind:=i;
end;
end;
writeln('Точка под номером ',minind,'.');
end.

(8.2k баллов)