Написать программу которая задаёт массив случайных чисел из 20элементов от 0 до 25 и...

0 голосов
24 просмотров

Написать программу которая задаёт массив случайных чисел из 20элементов от 0 до 25 и просчитывает сумму четных значений элементов


Информатика (16 баллов) | 24 просмотров
Дан 1 ответ
0 голосов

Var a: array[1..20] of Integer;
i,n,sum: Integer;
begin
for i:=1 to 20 do
begin
n:=random(25);
a[i]:=n;
writeln(i,' число: ',n);
end;
for i:=1 to 20 do
begin
if a[i] mod 2=0 then Inc(sum,a[i]);
end;
writeln(sum);
end.

(5.6k баллов)
0

Здравствуйте, можете пожалуйста помочь с https://znanija.com/task/29114100 ?