Программисты, помогите!!!! нужно написать программу ** паскале дано натуральное число n....

0 голосов
65 просмотров

Программисты, помогите!!!! нужно написать программу на паскале дано натуральное число n. Найти произведение нечетных чисел от 1 до n. C Longint и integer.


Информатика (96 баллов) | 65 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  Writeln(Range(1,ReadInteger,2).Aggregate(BigInteger(1),(p,q)->p*q))
end.
(150k баллов)
0 голосов

Var
  n, i: integer;
  pr: longint;

begin
  readln(n);
  pr := 1;
  i := 1;
  while (i <= n) do begin<br>    i := i + 2;
    pr := pr * i;
  end;
  pr := pr div i;
  writeln(pr);
end.

(1.0k баллов)