Программисты, помогите!!!! нужно написать программу ** паскале. дано натуральное число n....

0 голосов
86 просмотров

Программисты, помогите!!!! нужно написать программу на паскале. дано натуральное число n. Возвести в степень n число 2. С Longint и integer.


Информатика (96 баллов) | 86 просмотров
0

Это делается так

0

// PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018begin Writeln(BigInteger(2)**ReadInteger)end.

0

Пример: 5003273390607896141870013189696827599152216642046043064789483291368096133796404674554883270092325904157150886684127560071009217256545885393053328527589376

0

Это было 2 в степени 500

Дано ответов: 2
0 голосов
Правильный ответ

Var
  n, i: longint;
  a: int64;

begin
  readln(n);
  a := 2;
  for i := 2 to n do
    a := a * 2;
  writeln(a);
end.

(1.0k баллов)
0 голосов

Program z1;
var a,n:longint;
c:real;
begin
writeln('Введите N=');
read(n);
a:=2;
c:=power (a,n);
writeln(c);
end.

(1.2k баллов)