ПОМОГИТЕ С ИНФОРМАТИКОЙ!!!! Написать программу в Паскале 1. Заданы стороны треугольника....

0 голосов
55 просмотров

ПОМОГИТЕ С ИНФОРМАТИКОЙ!!!!

Написать программу в Паскале

1. Заданы стороны треугольника. Проверить является ли он прямоугольным


Информатика (17 баллов) | 55 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

В прямоугольном треугольнике должна выполняться теорема Пифагора. Найдем самую длинную строну и проверим, является ли квадрат ее длины суммой квадратов длин двух других сторон. Для того, чтобы избежать ошибок округления примем, что все длины - натуральные числа.

PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (a,b,c):=ReadReal3('Введите через пробел или Enter стороны:');
  if a>c then Swap(a,c);
  if b>c then Swap(b,c);
  if c*c=a*a+b*b then Writeln('Треугольник прямоугольный')
  else Writeln('Треугольник не прямоугольный')
end.

Пример
Введите через пробел или Enter стороны: 6 8 10
Треугольник прямоугольный

(150k баллов)
0

Я же написал

0

Найти сумму нечетных чисел в промежутке от 20 до n

0

Тоже в Паскале

0

Я не вижу, где задание выложено это

0

Я вам тут написал

0

У меня баллов больше нет(

0

Или Вы надеетесь, что я буду решение писать в комментарии? Это запрещено Правилами, в комментарии может быть только информация, относящаяся к данному заданию или решению.

0

Баллов нет - это Ваша проблема. Халявы тут тоже нет, каждый должен сервису что-то отдать, чтобы получить взамен. Решите в любом предмете задания для любого класса, наберите баллы.

0

Спасибо, могли бы просто нет сказать

0

Обычно пользователи просто "Нет" не понимают. Приходится объяснять, что есть ПРАВИЛА, которые они почему-то не читают, хотя при регистрацию соглашаются выполнять.