Помогите составить программу.

0 голосов
10 просмотров

Помогите составить программу.


image

Информатика (56 баллов) | 10 просмотров
0

на каком языке?

0

паскаль

Дан 1 ответ
0 голосов
Правильный ответ

Program z;
uses Crt;
var a,b,c,d:Integer;
begin
write('Введите два натуральных числа: ');
read(a,b);
c:=a;
d:=b;
while (a<>0) and (b<>0) do
begin
if a>b then a:=a-b
else b:=b-a;
end;
Write('НОД('+c+','+d+')=');
if a>b then Write(a)
else Write(b);
end.

(1.6k баллов)