Помогите с информатикой!!! Составить программу в Паскале 1. Найти сумму нечетных чисел...

0 голосов
71 просмотров

Помогите с информатикой!!!
Составить программу в Паскале

1. Найти сумму нечетных чисел в промежутке от 20 до n


Информатика (15 баллов) | 71 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Берем первое нечетное в этом диапазоне (21) и прибавляем к нему все числа через одно (т.е. тоже все нечетные), пока не выйдем за пределы n.

PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  Writeln('S=',Range(21,ReadInteger('n='),2).Sum)
end.

Пример
n= 250
S=15525

(150k баллов)
0

Программа работает несколько иначе: генерирует последовательность нечетный чисел на интервале [21;n] и находит ее сумму.

0

*нечетных: описка

0

Эффективность программы достигается тем, что последовательности в PascalABC.NET не хранятся, т.е. памяти не занимают, какой бы длины они не были.