Помогите написать программу в Pascal.Нужно написать программу для нахождения значения...

0 голосов
49 просмотров

Помогите написать программу в Pascal.Нужно написать программу для нахождения значения выражения:


image

Информатика (22 баллов) | 49 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.3.5, сборка 1636 от 10.03.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (a,c,x):=ReadReal3('Введите a,c,x:');
  var y:=(2*a-a/23)/Sqrt(1+a/4);
  var z:=(2*c-4*y+Abs(a-y))/(Exp(x)+2*a*y*a);
  Writeln('Y=',y,', Z=',z)
end.

Пример
Введите a,c,x: 3.5 -0.167 3.11
Y=5.00094509026456, Z=-0.129959221453275
(150k баллов)
0 голосов

Program ex1;uses crt;var y, x, z, a, c : real;begin  readln(a, c);  y:= (2 * a - (a / 23)) / (sqrt(1 + (a / 4)));  z:= (2 * c - 4 * y + abs(a - y)) / (exp(1) * x + 2 * a * y * a);  writeln(y);  writeln(z);end.

(440 баллов)
0

Напиши пожалуйста свою версию, буду очень благодарен

0

Скорее всего в степени x

0

У нас так учительница пишет