Помогите написать программу для с++ Найти такое натуральное число M, которое при...

0 голосов
43 просмотров

Помогите написать программу для с++
Найти такое натуральное число M, которое при развороте даст натуральное число N.
Sample Input:
1185671
Sample Output:
1765811
Заранее спасибо


Информатика (20 баллов) | 43 просмотров
Дан 1 ответ
0 голосов

#include
using namespace std;

int main()
{
int m,n,a,b;
n=0;
cin>>m;
while(m!=0)
{
d=m%10;
m=m/10;
n=d+n*10;
}
cout<<endl<<n<<endl;<br>system("pause");
return 0;
}

Вроде-бы работает как надо,удачи:)

(306 баллов)
0

А оператор какой? ?

0

???

0

stdio.h?

0

оператор? Мб библиотека? пред телом напиши : #include

0

using namespace std;

0

using... писать в треугольных скобочках?

0

отредактировал вверху

0

Спасибо