Помогите решить задачу по программированию, пожалуйста!!Используя,а) оператор ветвленияб)...

0 голосов
46 просмотров

Помогите решить задачу по программированию, пожалуйста!!

Используя,
а) оператор ветвления
б) оператор цикла
написать программу нахождения наибольшего из пяти чисел, вводимых с клавиатуры.
Pascal


Информатика (15 баллов) | 46 просмотров
0

Это Паскаль ?

0

Да!

Дан 1 ответ
0 голосов
Правильный ответ

Разветвляющийся алгоритм

Var a,b,c,d,e:integer;

Begin

Writeln('Введите значения переменных');

Readln(a,b,c,d,e);

If (a>b) and (a>c) and (a>d) and (a>e) tnen

Writeln('Наибольшее из 5 чисел ', a)

Else

If (b>a) and (b>c) and (b>d) and (b>e) tnen

Writeln('Наибольшее из 5 чисел ', b)

Else

If (c>a) and (c>b) and (c>d) and (c>e) tnen

Writeln('Наибольшее из 5 чисел ', c)

Else

If (d>a) and (d>b) and (d>c) and (d>e) tnen

Writeln('Наибольшее из 5 чисел ', d)

Else

Writeln('Наибольшее из 5 чисел ', e);

End.



Циклический алгоритм

Type

Vector=array [1..10] of integer;

Var m:integer;

a:vector;

i:byte;

Begin

Writeln('Введите значения переменных');

For i:=1 to 5 do

      Readln (a[i]);

For i:=1 to 5 do

If  a[i]>a[i+1] then

m:=a[i];

Writeln('Наибольшее число ', m);

End.

(436 баллов)