Составить программу по условию: дан массив из 10 элементов.Найти сумму элементов, кратных...

0 голосов
37 просмотров

Составить программу по условию: дан массив из 10 элементов.Найти сумму элементов, кратных 3 и двузначных. Массив задан случайно
на паскале


Информатика (12 баллов) | 37 просмотров
0

русский не родной. суммируем двузначны равные 3м? или отдельно двузначные и отдельно кратные 3м?

Дан 1 ответ
0 голосов

Так как задание не формализовано выводит последовательно суммы кратных 3 и двухзначных чисел

Program TZ5;
const
n=10;
var
a:array [1..n] of integer;
i,b:integer;
begin
randomize;
for i:=1 to n do begin
 a[i]:=random (20);
 a[i]:=a[i]-10;
        writeln(i,'  ',a[i]);
end;
b:=0;
for i:=1 to n do
    if (a[i] mod 3)=0 then
       b:=b+a[i];
writeln('summa kratnyh 3m=',b);
b:=0;
for i:=1 to n do
    if abs(a[i]) >9 then b:=b+a[i];
writeln('summa dvuhznachnyh =',b);
readln;
end.

(340 баллов)