1) Написать программу, которая вычисляет сумму первых n целых положительных чисел....

0 голосов
90 просмотров

1) Написать программу, которая вычисляет сумму первых n целых положительных чисел. Количество суммируемых чисел должно вводиться во время работы программы. (Использовать цикл While)


Информатика (16 баллов) | 90 просмотров
Дано ответов: 2
0 голосов

Var
  n, a, sum, i: longint;

begin
  readln(n);
  sum := 0;
  i := 1;
  while (i <= n) do beign<br>    read(a);
    sum := sum + a; 
    inc(i);
  end;
  writeln(sum);
end.

(1.0k баллов)
0 голосов

Var i,s,n:Integer;
begin
ReadLn(n);
while ibegin
i:=i+1;
s:=s+i
end;
WriteLn(s)
end.

(3.9k баллов)