СРОЧНО!!!!!!!!!! Написать программу в Паскаль 1) Дано n число, верно ли, что сумма его...

0 голосов
39 просмотров

СРОЧНО!!!!!!!!!!
Написать программу в Паскаль
1) Дано n число, верно ли, что сумма его цифр четное число
2) Найдите сумму его цифр больше 5

СРОЧНО!!!!!!!!!


Информатика (14 баллов) | 39 просмотров
Дан 1 ответ
0 голосов

Первая
var n,a:integer;
begin
a:=0;
WriteLn(n);
while n>0 do
begin
a:=a + (n mod 10);
n:=n div 10;
end;
end.

Вторая
var n,a:integer;
begin
a:=0;
WriteLn(n);
while n>0 do
begin
if n mod 10>5 then
begin
a:=a + (n mod 10);
end;
n:=n div 10;
end;
end.

(51 баллов)