Написать программу в Pascal по 2 способам repeat и while.Сделать блок-схему.ПОЖАЛУЙСТА...

0 голосов
140 просмотров

Написать программу в Pascal по 2 способам repeat и while.Сделать блок-схему.ПОЖАЛУЙСТА РЕШИТЕ УМОЛЯЮ 99БАЛЛОВ


image

Информатика (100 баллов) | 140 просмотров
0

Так вот я и прошу, потому что я не знаю как делать

0

Хорошо

0

Спасибо, с блок-схемой не поможете?

0

в обоих

0

Это в каком способе поменять строки?

0

нет, только если подскажу. кстати, поменяйте местами строкиi := i + 1;s := s + i*cos(i*x); должно быть наоборотs := s + i*cos(i*x); i := i + 1;

0

А со следующим заданием не поможете? Я его отдельным заданием выложу за 50 баллов. Заранее спасибо

0

Хорошо спасибо

0

ну я сделаю набросок схемы сейчас, как я это вижу

0

нужно понять как работают циклы while и repeat, введите в поисковике и посмотрите, попробуйте составить свой. так и научитесь

Дан 1 ответ
0 голосов
program M;
var i: integer = 2;
s: double = 0;
x: integer = 2;
begin
while (i<=15) do<br>begin
s := s + i*cos(i*x); 
i := i + 1;
end;
writeln('S= ', s:0:2);
end.
а вот с repeat until

program M;
var i: integer = 2;
s: double = 0;
x: integer = 2;
begin
repeat
s := s + i*cos(i*x); 
i := i + 1;
until i>15;
writeln('S= ', s:0:2);

image
(898 баллов)
0

в обоих случаях Х задаётся при инициализации, в условии не сказано про то как это нужно сделать. но разумнее конечно вводить его с клавиатуры

0

Сделайте пожалуйста я просто уже не знаю что делать завтра последний срок сдачи работы я выложил задание

0

попробуйте составить эту блок-схему смотря на те что я уже нарисовал. должно быть какое-то условие, условие рисуется как ромб, в данном случае в ромбе должно проверятся оканчивается ли число на 3. сложно в общем. тут я бы переводил в строку и брал последний символ. можно и математически это сделать, но это сложнее

от ромба должно быть две стрелки, одна "да", другая "нет". когда условие выполняется то "да" и наоборот

0

Пожалуйста очень нужно

0

Задание:Вывести на экран числа оканчивающаяся на 3 в промежутке от n до 150. СДЕЛАТЬ ТОЛЬКО БЛОК СХЕМУ. По 2 способам for и while.

0

мне не нужны ваши баллы. покажите задание, я подскажу

0

Может все таки можете с следующим задание там только блок схема, за 80 баллов

0

Спасибо

0

нет, и не потому что мне лень или тяжело. а потому что в этом не будет никакой пользы, ни для вас, ни для меня