Напишите программу, которая будет менять местами в каждой строке двумерного массива...

0 голосов
67 просмотров

Напишите программу, которая будет менять местами в каждой строке двумерного массива минимальный и последний элемент.


Информатика (15 баллов) | 67 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
PascalABC.NET 3.4.0, сборка 1671 от 31.05.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (m,n):=ReadInteger2('Количество строк и столбцов в массиве:');
  Writeln('*** Исходный массив ***');
  var a:=MatrRandom(m,n,-99,99);
  a.Println(4); Writeln(4*a.ColCount*'-');
  for var i:=0 to a.RowCount-1 do begin
    var row:=a.Row(i);
    var imin:=row.IndexMin;
    Swap(row[imin],row[row.High]);
    a.SetRow(i,row)
    end;
  Writeln('*** Полученный массив ***'); a.Println(4)
end.

image
(150k баллов)