Нужно написать программу ** с++, которая будет решать введенные в нее производные,...

0 голосов
33 просмотров

Нужно написать программу на с++, которая будет решать введенные в нее производные, например 2x^5 = 10x^4, cosx = - sinx, вычислять ответ производной не нужно.


Информатика (195 баллов) | 33 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//Microsoft (R) C/C++ Optimizing Compiler Version 19.00.23506 for x64

#include
#include
#include
#include

int main()
{
    std::vector> deriv_sheet = {
        std::make_pair("2x^5", "10x^4"),
        std::make_pair("cosx", "-sinx")
    };
    std::string user_fx;
    std::cin >> user_fx;
    for (const auto& i : deriv_sheet )
        if (i.first.compare(user_fx) == 0)
            std::cout << i.second;<br>}

(4.2k баллов)
0

Да, мне не подходит. У меня доступ к некоторым ресурсам идет через неповинные ни в чем Амазон и Гyгл, которые РКН частично забанил.

0

Ладно...не стоит тут дальше продолжать

0

Ахаха, да, ато опять придут, скажут наспамили))

0

Личку закрыли, сказали, что надо все тут обсуждать, открыто)) Но меру все же надо знать.

0

Да, я вижу вообще все поубирали, даже комментарии в профиле

0

Ну вот....ссылки публиковать нельзя, к обсуждению не пригласишь куда-то, потому что не будешь же светить тут свои логины. Остается только тут.

0

Жестоко, как всегда..

0

https://znanija.com/task/29277524 - вот условие, просто песня ))

0

Смотрите, здесь Эникей выше давал пример, одного из решений вашей проблемы, но как и ранее было сказано, нужна адекватная постановка задания, незачем плодить новые темы, там вам вряд ли дадут ответ "лучше".

0

Я считаю, возможен вариант построение синтаксического дерева, которое анализировало бы введенную fx и в соответствии могло принимать меры.. Как вариант часть производных типо cosx = - sinx можно подставлять из файла например где есть некая табличка