Написать программу, которая вычисляет сумму первых n целых положительных целых чисел....

0 голосов
185 просмотров

Написать программу, которая вычисляет сумму первых n целых положительных целых чисел. Количество суммируемых чисел должно вводиться во время работы программы. Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены жирным шрифтом).
Вычисление суммы положительных чисел.
Введите количество суммируемых чисел —> 20
Сумма первых 20 положительных чисел равна 210


Информатика (15 баллов) | 185 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

С++


#include#include #includeusing namespace std;int main(){setlocale(0, "");int i, b = 0;cout << "Вычисление суммы положительных чисел.\nВведите количество суммируемых чисел —>";cin >> i;for (int f = 1; f <= i; f++){ b += f;}cout << "Сумма первых " << i << " положительных чисел равна " << b;    return 0;}<hr>image

(93 баллов)
0

Что то не могу я понять

0

Что именно?

0

Считывает количество суммируемых чисел. Затем цикл от 1 до введённого числа. В цикле мы суммируем все числа от 1 до введённого числа. Затем выводим ответ.

0

А в моем случае какой будет ответ?