Написать программу ** языке программирования Pascal для решения следующей задачи: дан...

0 голосов
58 просмотров

Написать программу на языке программирования Pascal для решения следующей задачи: дан массив из 16 целых чисел. Вывести массив на экран в виде таблицы из четырёх строк и четырёх столбцов. Ввод массива, вывод массива оформить в виде подпрограммы.

Заранее огромное спасибо.


Информатика (15 баллов) | 58 просмотров
0

Да, это современный Паскаль, отражающий нынешние тенденции в программировании. Мощный и емкий, взявший все лучшее, что можно было взять от языков C#, Python и Haskell и позволяющий использовать любый средства платформы .NET Windows. Паскаль, на котором любая школьная программа пишется в несколько строчек.

0

Это Паскаль, который позволяет не огорчаться даже "продвинутых" из-за того, что в школе отведено недостаточно времени на изучение C++ или C#: время перехода на C# с него при необходимости не превышает пару месяцев.

0

Вам нужен "древний паскаль"? Тогда пишите в вопросе, что нужна программа на языке Pascal ABC (именно так, через пробел) или Free Pascal. Можете повторить вопрос за минимум баллов, я Вам дам решение. Уже хотя бы для того, чтобы Вам было с чем сравнить)))

0

Товарищи информатики и гуру Паскаля, прошу вас сделать блок-схему к данной задаче.))))

0

Как дать баллы за это?

0
0

Что значит "дать баллы"? Там стоит 8 баллов

0

Я создал новый вопрос, ссылка выше. 15 баллов

0

По блок-схемам. Различают блок-схему, поясняющую алгоритм решения, которая не привязана к языку программирования и блок-схему, которая поясняет конкретную программу. Они совершенно по-разному выполняются, потому что стандарт (ГОСТ/ISO) предъявляет разные правила к их построению.

0

15 баллов - это Вы потратили. Внизу страницы есть ссылка "Общие вопросы" - выберите там среднюю кнопочку и почитайте раздел "Баллы". Поймете, во что и почему превратились Ваши 15 баллов.

Дан 1 ответ
0 голосов
Правильный ответ
PascalABC.NET 3.4.0, сборка 1672 от 10.06.2018
Внимание! Если программа не работает, обновите версию!

function ВводМассива:=ReadArrInteger('Введите 16 чисел через пробел:',16);

procedure ВыводМассива(a:array of integer);
begin
  foreach var p in a.Batch(4) do begin
    foreach var q in p do Write(q:4);
    Writeln
    end
end;

begin
  ВыводМассива(ВводМассива)
end.

image
(150k баллов)