Написать программу на языке C++, которая создает и выводит 2x2 квадратную матрицу на экран. После того как матрица появилась на экране, программа должна посчитать её определитель.
#include #include using namespace std; int main() { setlocale(0, "RUS"); srand(time(NULL)); int matr[2][2]; cout << "Сгенерированная матрица:" << endl;<br> for (int i = 0; i < 2; i++) { for (int j = 0; j < 2; j++) { matr[i][j] = rand() % 10; cout << matr[i][j] << " ";<br> } cout << endl;<br> } cout << "Определитель матрицы: " << matr[0][0] * matr[1][1] - matr[0][1] * matr[1][0] << endl;<br> system("pause"); }
Спасибо))
#include #include int main() { std::vector> v2d = { { 5, 4 }, { 3, 5 } }; for (const auto& i : v2d) for (const auto& j : i) std::cout << j;<br> std::cout << v2d.at(0).at(0) * v2d.at(1).at(1) - v2d.at(0).at(1) *<br>v2d.at(1).at(0); }
Привет дорогой друг! Не поможешь мне пожалуйста с этим? https://znanija.com/task/29319148
И с этим тоже, пожалуйста.
https://znanija.com/task/29319150