Написать программу, которая по введенному значению аргумента вычисляет значение функции,...

0 голосов
137 просмотров

Написать программу, которая по введенному значению аргумента вычисляет значение функции, заданной в виде графика. (Turbo Pascal) а так же блок-схему ( необязательно)
Буду очень благодарен!
Заранее спасибо.


image

Информатика (12 баллов) | 137 просмотров
0

Блин, люди, уже почти пол лета прошло, а вы тут фигней занимаетесь. Кто вам придумывает такие задачи дикие? Кому это нужно?

Дан 1 ответ
0 голосов

Function Foo(x: real): real;
begin
   if (-9 <= x) and (x <= -5) then<br>      result := 2 - Sqrt(4 - Sqr(x + 7))
   else if (-5 <= x) and (x <= -4) then<br>      result := 2
   else if (-4 <= x) and (x <= 0) then<br>      result := -(1 / 2) * x
   else if (0 <= x) and (x <= Pi) then<br>      result := Sin(x)
   else if x >= Pi then
      result := x - Pi;
end;

var
    x: real;

begin
   writeln('x =');
   readln(x);
   if x < -9 then
   begin
      writeln('функция не определена в этой области');
      exit
   end
   else Writeln('y = ',Foo(x));
end.

(2.5k баллов)
0

Извините!, видимо забыл указать нужно что бы R вводилось с клавиатуры.
А на ваш вопрос "Кому это нужно" учителям...

0

Можете еще раз написать программу?
Эту задачу нужно решить в кратчайшие сроки тобишь сегодня.
Простите еще раз что не указал.

0

В следующий раз пиши в какой IDE: FPC, PascalABC.NET

0

Не могу изменить ответ почему то, почему ты знаешь?

0

Изменить не можешь потому-что надо заново писать ответ.

0

и ответить не могу, нет поля для ввода