Написать программу в Pascal Даны число A>0, числа x1,x2.... Необходимо вводить числа...

0 голосов
19 просмотров

Написать программу в Pascal

Даны число A>0, числа x1,x2....
Необходимо вводить числа x1,x2.... , пока сумма модулей введенных чисел будет меньше A. Определить число введенных чисел.

P.S В поисковике искал, нашел 2 какие-то странные программы, они мне не подходят


Информатика (17 баллов) | 19 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
  a,x,k,s:integer;
begin
  Write('a=');
  Readln(a);
  k:=0;
  s:=0;
  while s  begin
    Read(x);
    s:=s+abs(x);
    Inc(k)
  end;
  Writeln('Введено чисел ',k)
end.

(2.0k баллов)
0

"пока сумма модулей введенных чисел будет меньше A", а твоя программа считает вроде как равное числу А, или я неправильно понимаю задачу?