Написать программу, которая запрашивает слово и проверяет, является ли это слово...

0 голосов
159 просмотров

Написать программу, которая запрашивает слово и проверяет, является ли это слово палиндромом. Pascal ABC


Информатика (15 баллов) | 159 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

var

    s: string;


function Invert(s: string): string;

var

    i: integer;

    t: string;

begin

    t := '';

    for i := 1 to length(s) do

        t := s[i] + t;

    

    Invert := t;

end;


begin

    Write('Введите слово: ');

    Readln(s);

    

    s := Trim(s);

    s := Uppercase(s);

    

    if Invert(s) = s then 

        Writeln('Палиндром')

    else 

        Writeln('Не палиндром');

end.


(55.0k баллов)
0

бывает. и если это заметят то снимают отметку и отправляют на исправление или вообще удаляют ответ

0

ответов море. и там не только опечатки но и спам и все что попало валяется. Архив это громадное нагромаждение которое проверять и проверять.

0

Потому мы проверяем более менее популярные только

0

это добровольная работа

0

подарки один раз присылали

0 голосов

Var
  s:string;
  i,n:byte;
  p:boolean;
begin
  Write('Введите слово: ');
  Readln(s);
  n:=Length(s);
  p:=true;
  for i:=1 to n div 2 do
    if s[i]<>s[n-i+1] then
    begin
      p:=false;
      break
    end;
  if p then Writeln('Палиндром')
  else Writeln('Не палиндром')
end.

(2.0k баллов)
0

"Анна" уже не палиндром?