Написать программу ** языке Pascal (цикл for и while ). Найти сумму нечетных чисел в...

0 голосов
152 просмотров

Написать программу на языке Pascal (цикл for и while ). Найти сумму нечетных чисел в промежутке от 20 до n


Информатика (52 баллов) | 152 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var
  i,n,s:integer;
begin
  Write('n=');
  Readln(n);
  s:=0;
  for i:=20 to n do
    if Odd(i) then s:=s+i;
  Writeln('Сумма с for = ',s);
  s:=0; i:=21;
  while i<=n do<br>  begin
    s:=s+i;
    i:=i+2
  end;
  Writeln('Сумма с while = ',s)
end.

(2.0k баллов)
0 голосов

Program l;

var

i, n, s: integer;

begin

writeln('Введите n');

readln(n);

for i = 20 to n do begin

if (i mod 2 <> 0) then

s := s + i;

end;

write(s);

end.


(1.3k баллов)
0

а через while это можно как-то сделать?