Напишите программу, при помощи которой можно подсчитать расходы ** доставку мебели....

0 голосов
51 просмотров

Напишите программу, при помощи которой можно подсчитать расходы на доставку мебели. Исходные данные для расчета – номер этажа и информация о наличии и типе лифта (грузовой или обычный). C++


Информатика (12 баллов) | 51 просмотров
Дан 1 ответ
0 голосов

Надеюсь без ошибок. Цену за отдельные аспекты назначте сами:

#include stdlib.h
#include
using namespace std;

int main() {
setlocale(LC_ALL, "Russian");

int floor;
char lift, type0;
double price_floor;
double price_elevator;
double price_type;
double total_price;
bool elevator;

cout << "Введите номер этажа: ";<br>cin >> floor;

if (floor == 1 || floor <= 3) price_floor=1;<br>if (floor <= 6 && floor > 3) price_floor=2;
if (floor <= 9 && floor > 6) price_floor=3;
else if price_floor=4;

cout << "Имеется ли в вашем помещении лифт? "; //Ответ + или -<br>cin >> lift;
switch (lift) {
case '+':
price_elevator=1;
elevator=true;
break;
case '-':
price_elevator=2;
break;
}

if (elevator) {
cout << "Грузоподъемный? ";<br>cin >> type0;
switch (type0) {
case '+':
price_type=1
break;
case '-':
price_type=2;
break;
}
}
else if cout <<"\n";<br>cout <<"\n";<br>total_price=price_elevator + price_floor + price_type;
cout << "Конечная цена: " << total_price <<endl;<br>system ("pause");
return 0;
}

(256 баллов)