Напишите программу, которая выводит ** экран числа от 1 до 100. При этом вместо чисел,...

0 голосов
207 просмотров

Напишите программу, которая выводит на экран числа от 1 до 100. При этом вместо чисел, которые оканчиваются на тройку(Например 33, 13, 73, 43 и т д), программа должна выводить слово «Fizz»


Информатика (31 баллов) | 207 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

var i:integer;

begin

for i:=1 to 100 do

if i mod 10=3 then write(' Fizz ')

else write(i,' ');

end.


Результат:

1 2 Fizz 4 5 6 7 8 9 10 11 12 Fizz 14 15 16 17 18 19 20 21 22 Fizz 24 25 26 27 28 29 30 31 32 Fizz 34 35 36 37 38 39 40 41 42 Fizz 44 45 46 47 48 49 50 51 52 Fizz 54 55 56 57 58 59 60 61 62 Fizz 64 65 66 67 68 69 70 71 72 Fizz 74 75 76 77 78 79 80 81 82 Fizz 84 85 86 87 88 89 90 91 92 Fizz 94 95 96 97 98 99 100

(194k баллов)
0

Мне надо в PHP

0 голосов

<?php</p>

for($i = 1; $i <= 100; $i++){</p>

if($i % 10 == 3){

echo "Fizz\n";

}else{

echo $i;

echo "\n";

}

}

?>

(4.8k баллов)