Срочно нужно написать программу ** Pascal. Программа должна выводить 20 случайных чисел...

0 голосов
43 просмотров

Срочно нужно написать программу на Pascal. Программа должна выводить 20 случайных чисел от 1 до 26 и чтобы они не повторялись. Числа должны сохранятся в массиве. Заранее Спасибо!


Информатика (19 баллов) | 43 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a:array[1..20] of integer;
c,b,i,d: integer;
begin
c:=0;
b:=0;
for i:= 1 to 20 do
begin
a[i]:=random (1,26);
while (b <> 1) do
begin
for d:= 1 to i-1 do
if (a[i] = a[d]) then c:=1;
if (c = 1) then a[i]:=random (1,26) else b:=1;
c:=0;
end;
end;
for i:= 1 to 20 do
writeln(a[i]);
end.

P.S. Не уверен что правильно,т.к. не могу проверить программу в паскале

(388 баллов)
0

числа повторяются у меня также получалось)

0

но всё равно спасибо. и если не трудно постарайся переделать)