Написать программу (в паскале ) . Определить сдачу после покупки булки хлеба и двух...

0 голосов
132 просмотров

Написать программу (в паскале ) . Определить сдачу после покупки булки хлеба и двух пакетов молока .


Другие предметы (12 баллов) | 132 просмотров
Дан 1 ответ
0 голосов

program Kassa;

var cash, bread, milk, cost, cashback: integer;

begin

writeln('Цена молока: ');

readln(milk);

writeln('Цена хлеба: ');

readln(bread);

writeln('Внесено денег: ');

readln(cash);

cost := milk + bread;

if cash < cost

then begin writeln('Недостаточно средств!'); end

else begin cashback := cash - cost; writeln('Сдача: ',cashback); end

end.

(234 баллов)
0

Корректировка: над командой cost := milk + bread, добавить это: "milk := milk * 2", а то процессе программирования забыл про два пакета молока.