Написать программу в паскале Автобус провозит 50 пассажиров. Из них 10 едут до первой...

0 голосов
75 просмотров

Написать программу в паскале Автобус провозит 50 пассажиров. Из них 10 едут до первой станции, 20 - до второй, а остальные до конечной. стоимость билетов до каждой станции соответственно равна a,b,c. Определите сколько рейсов должен делать автобус. чтобы выручка составила К руб?


Информатика (16 баллов) | 75 просмотров
Дан 1 ответ
0 голосов

var a, b,c,k,d,e,g,h : integer;

var f : integer;

begin

writeln('Введите стоимости билета за проезд до первой, до второй и до конечной станции через пробел :');

readln(a,b,c);

writeln('Введите сколько рублей должна быть конечная выручка : ');

readln(k);

d := 10*a;

e := 20*b;

g := 20*c;

h := d+e+g;

f := h div k;

writeln(f, ' Рейсов нужно совершить нужно совершить.');

end.

Лог :

Введите стоимости билета за проезд до первой, до второй и до конечной станции через пробел :

1

1

1

Введите сколько рублей должна быть конечная выручка :  

50

1 Рейсов нужно совершить нужно совершить.

(74 баллов)