Помогите пожалуйста. Написать программу, которая ** вход получает 2 множества, а при...

0 голосов
54 просмотров

Помогите пожалуйста.
Написать программу, которая на вход получает 2 множества, а при выходе даёт 4 множества.
Можно на любом языке программирования.
А ещё если не сложно , на псевдокоде. Пожалуйста


Информатика (15 баллов) | 54 просмотров
0

1 байт

0

Пробуй. Размер с клавиатуры вводить.

0

Окей, буду знать)

0

Если есть желание и немного знаний и понимания математики, то учить не сложно и даже интересно

0

Офигеть в инете С++ выучиться, вот это ты бог программирования

0

В интернете научился :)

0

Мне кажется препод мне не поверит я сказал типо не умею кодить, типо на псевдокоде напишу. Ну Лан скажу помогал дядя программист и т.д.

0

Хм)))))

0

А на псевдокоде как будет выглядеть это?

0

Browze спасибо большое

Дано ответов: 2
0 голосов
Правильный ответ

// PascalABC.NET 3.4, сборка 1766 от 25.08.2018


begin  

 var a := new HashSet(ReadArrInteger('Множество A ->', ReadInteger('Размер множества A =')));

 var b := new HashSet(ReadArrInteger('Множество B ->', ReadInteger('Размер множества B =')));

 a.Except(b).Print; Println(' - A\B');

 b.Except(a).Print; Println(' - B\A');

 a.Intersect(b).Print; Println(' - пересечение A и B');

 a.Union(b).Print; Println(' - объединение A и B');

end.

Пример ввода/вывода в приложении.



image
(5.8k баллов)
0

Ну так это же замена WriteFormat

0

её уберут в дальнейшем?

0

Ну я же на разработчик. Пока не собираются.

0

Но в любом случае все, что начинается с Write объявляется устаревшим везде, кроме вывода в файлы.

0

Интерполированные строки можно присваивать переменным и впоследствии редактировать. Это ведь на самом деле обычная строка.

0

Т.е. формат будет как расширение величины ))))

0

Но с восхитительной генерацией)

0

Признак интерполяции - как раз $

0

Прикольно, полная замена форматной печати через Writeln

0

А интерполируется контекст в фигурных скобках.

0 голосов

Кроме C++ ничего не знаю.

g++ compiler


#include

#include

#include

#include


int main()

{

   std::set

       set1,//Первое входное множество(A)

       set2,//Второе выходное множество(B)

       set3,//Первое выходное(разность set1 и set2)

       set4,//xz

       set5,//A пересечение B

       set6;//A объединение B

   int

       N, M,

       temp;

   

   std::cout << "Введите размер первого и второго множеств:";</p>

   std::cin >> N >> M;

   

   

   std::cout << std::endl << "Введите значения первого множества: ";</p>

   for(int i = 0; i < N; i++)

   {

       std::cin >> temp;

       set1.insert(temp);

   }

   

   std::cout << std::endl << "Введите значения второго множества: ";</p>

   for(int i = 0; i < M; i++)

   {

       std::cin >> temp;

       set2.insert(temp);

   }

   std::set_difference(set1.begin(), set1.end(), set2.begin(), set2.end(), std::inserter(set3, set3.begin()));

   std::set_difference(set2.begin(), set2.end(), set1.begin(), set1.end(), std::inserter(set4, set4.begin()));

   std::set_intersection(set1.begin(), set1.end(), set2.begin(), set2.end(), std::inserter(set5, set5.begin()));

   std::set_union(set1.begin(), set1.end(), set2.begin(), set2.end(), std::inserter(set6, set6.begin()));

   

   //вывод

   std::cout << "Множество А: ";</p>

   std::copy(set1.begin(), set1.end(),

       std::ostream_iterator(std::cout, " "));

   std::cout << std::endl;</p>

   

   std::cout << "Множество B: ";</p>

   std::copy(set2.begin(), set2.end(),

       std::ostream_iterator(std::cout, " "));

   std::cout << std::endl;</p>

   

   std::cout << "Множество А - B: ";</p>

   std::copy(set3.begin(), set3.end(),

       std::ostream_iterator(std::cout, " "));

   std::cout << std::endl;</p>

   

   std::cout << "Множество B - A: ";</p>

   std::copy(set4.begin(), set4.end(),

       std::ostream_iterator(std::cout, " "));

   std::cout << std::endl;</p>

   

   std::cout << "Множество A пересечение B: ";</p>

   std::copy(set5.begin(), set5.end(),

       std::ostream_iterator(std::cout, " "));

   std::cout << std::endl;</p>

   

   std::cout << "Множество А объединение B: ";</p>

   std::copy(set6.begin(), set6.end(),

       std::ostream_iterator(std::cout, " "));

   std::cout << std::endl;</p>

   return 0;

}


(4.0k баллов)
0

Я просто два продублировал задания, ну типо баллов больше получите

0

Сдавал в этом году :)

0

Мне лично баллов ненужно, а тем более с продублированного вопроса.

0

Я не знаю ._.

0

Вы можете это же самое написать у меня во втором задании

0

Офигеть

0

Возможно

0

С++ сложный язык с объемным кодом для выполнения простых задач.

0

Нельзя. Вообще повторные вопросы задавать не нужно. Это никак не ускорит процесс. Согласен ^

0

Хорошо, буду знать)