ПОМОГИТЕ ПОЖАЛУЙСТА С ИНФОРМАТИКОЙ СРОЧНО!!))) Составить программу Паскаль Ввести...

0 голосов
34 просмотров

ПОМОГИТЕ ПОЖАЛУЙСТА С ИНФОРМАТИКОЙ СРОЧНО!!)))
Составить программу Паскаль
Ввести координаты двух точек на плоскости ,на экран вывести номер четверти координатной плоскости.


Информатика (14 баллов) | 34 просмотров
Дан 1 ответ
0 голосов

program DotsAndKvadrants;

type

 dot = record

   x, y: real;

 end;

begin

 var n := 2;

 var a := new dot[n];//массив из точек

 for var i := 0 to n - 1 do

 begin

   (a[i].x, a[i].y) := ReadlnReal2($'Введите через пробел координаты {i+1} точки:');

   if a[i].x * a[i].y <> 0 then

   begin

     Write('Точка ', a[i], ' расположена в');

     if a[i].x * a[i].y > 0 then  

       if a[i].x > 0 then writeln(' 1-ом квадранте')

       else writeln(' 3-ем квадранте')

     else if a[i].x > 0 then writeln(' в 4-ом квадранте')

     else writeln('о 2-ом квадранте');

   end

   else if a[i].x = 0 then

     if a[i].y = 0 then

       Writeln('точка ', a[i], ' - начало координат')

     else Writeln('точка ', a[i], ' лежит на оси OX')

   else Writeln('точка ', a[i], ' лежит на оси OY')

 end;

end.

(2.5k баллов)
0

PascalABC.NET