Срочно! Помогите написать программу в паскале с данной блок схемой.
var
x,y:real;
begin
readln(x);
if x > 0 then
y := sqr(x) * 4
else if x < 0 then
y := x*x - 8
else
y := 12 / (x - 1); (*здесь x-1, потому что на 0 делить нельзя*)
writeln('x = ', x:2);
writeln('y = ', y:2);
end.
(readln(x); if x > 0 then)
Ошибку узнать-то можно?
ожидался символ ' '
При копировании из редактора добавляются новые символы. Напишите код вручную.
ошибка не исправляется..Почему?
Ошибка та же?
та же
Я прикрепил скриншот, где видно, что у меня все работает.
Компилятор у вас какой?
??