Написать программу pascal: найти сумму всех чисел с клавиатуры, кратных заданному числу...

0 голосов
43 просмотров

Написать программу pascal: найти сумму всех чисел с клавиатуры, кратных заданному числу a.


Информатика (62 баллов) | 43 просмотров
0

n-кол-во заданных чисел a-число из условии q-задаваемые числа

Дан 1 ответ
0 голосов
Правильный ответ

Program gt;
var n,a,i,s,q:integer;
begin
read(n);
read(a);
s:=0;
for i:=1 to n do
begin
read(q);
if(q mod a=0)then s:=s+q;
end;
writeln(s);
end.

(6.6k баллов)