15 баллов.Язык программирования Python. Нужно написать программу по примеру (фото 1),...

0 голосов
59 просмотров

15 баллов.Язык программирования Python. Нужно написать программу по примеру (фото 1), которая будет решать вот такое замысловатое уравнение и систему уравнений (фото 2). Я пробовала сама, но что-то не сходится, вылетают ошибки.


image
image

Информатика (990 баллов) | 59 просмотров
Дан 1 ответ
0 голосов

import math

def f(u, t):

   if (u < 2 * t):

       m = u ** (-1) - t ** (-1)

       return m

   elif (u > 2 * t):

       m = (u - t) ** 2

       return m

   else:

       m = (2 * u + 5 * t) / 3

       return m


x = float(input("x: "))

y = float(input("y: "))

z1 = f(math.fabs(math.log(x) + y) ,math.sin(y - x) / math.acos(x / y))

z2 = math.cos(math.sqrt(f(math.exp(y), (2 * x - 1) ** 3)))

z3 = math.tan(f(y / x, math.asin(x / y)))

print(z1 + z2 + z3)


Скачать вложение Текст (TXT)
(654k баллов)
0

хорошо)

0

отправь ещё раз, там все строки сбились.

0

я не знаю, он говорит, что там инвалидные строки находятся))

0

лайк, спасибо большое :*

0

слушай, там так получилось, что нужно потом эти z1, z2 и z3 не сложить вместе,как у тебя, а сделать так, чтобы в z3 уже вышел результат.то есть нужно один z вывести через другой. типо, z2=tan(z1) (это просто как пример).