Написать программу паскаль : вводится возраст человека выдать его статус 1-7 ребёнок 8-18...

0 голосов
43 просмотров

Написать программу паскаль : вводится возраст человека выдать его статус 1-7 ребёнок 8-18 школьник 19-24 студент 25-65 рабочий от 65 пенсионер


Информатика (46 баллов) | 43 просмотров
Дан 1 ответ
0 голосов

var years:integer;


begin

   readln(years);

   case years of

       1..7: writeln('Ребенок');

       8..18: writeln('Школьник');

       19..24: writeln('Студент');

       25..65: writeln('Рабочий');

       66..150: writeln('Пенсионер');(*Вряд ли до 150 кто-то доживет, но все же*)

   end;

end.


(4.0k баллов)
0

или var years:integer;begin readln(years); if years < 0 then begin writeln('Неверный возраст'); exit; end; case years of 1..7: writeln('Ребенок'); 8..18: writeln('Школьник'); 19..24: writeln('Студент'); 25..65: writeln('Рабочий'); else writeln('Пенсионер');(*Вряд ли до 150 кто-то доживет, но все же*) end;end.