Нужно составить программу, которая будет отвечать ** вопрос является ли число степенью...

0 голосов
25 просмотров

Нужно составить программу, которая будет отвечать на вопрос является ли число степенью двойки.Заранее спасибо!!!!


Информатика (976 баллов) | 25 просмотров
Дан 1 ответ
0 голосов

#include

#include


int main()

{

int number;

scanf("%d", &number);

number = abs(number);

if(number % 2 != 0)

{

 printf("Не является!");

 return 0;

}

while(number > 2)

{

 number /= 2;

}

if(number == 2)

 printf("Является!");

else printf("Не является!");

}


image
(4.0k баллов)
0

спасибо!

0

Это C, стандарт C99.Если у Вас компилятор не поддерживает стандарт C99, измените подключаемый файл stdlib.h на math.h.