Задача:Дан массив из 10 целых чисел,от -20 до 20 .Напишите программу,заменяющую первый...

0 голосов
26 просмотров

Задача:
Дан массив из 10 целых чисел,от -20 до 20 .
Напишите программу,заменяющую первый отрицательный элемент массива нулем.

Помогите пожалуйста решить!


Информатика (53 баллов) | 26 просмотров
0

язык?)

0

паскаль

Дано ответов: 2
0 голосов
Правильный ответ

Program z10;
var a,b:Array [1..10] of integer;
i,q:integer;
Begin
Randomize;
q:=0;
For i:=1 to 10 do
begin
a[i]:=random(40)-20;
write(a[i],' ');
if(a[i]<0)then begin<br>q:=q+1;
if(q=1)then a[i]:=0;
end;
end;
writeln;
for i:=1 to 10 do
begin
write(a[i],' ');
end;
end.

(6.6k баллов)
0 голосов

Var a:array [1..10] of integer;
     i,n,b:integer;
Begin
  for i:=1 to 10 do
    read(a[i]);
  for i:=1 to 10 do
  begin
    if b=0 then if a[i]<0 then <br>       begin
         a[i]:=0;
         b:=1;
       end;
  end;

  for i:=1 to 10 do
  write(a[i],' ');
End.

(280 баллов)