Напишите программу, которая вводит натуральные числа а и b и выводит ** экран все...

0 голосов
733 просмотров

Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр. Входные данные Входная строка содержит два натуральных числа – значения a и b , разделённых пробелами. Гарантируется, что a ≤ b . Выходные данные Программа должна вывести в одну строчку все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр. Числа разделяются пробелами. На Python


Информатика (130 баллов) | 733 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Для каждого числа создаём множество его цифр. Если все цифры числа ненулевые и число делится на каждую цифру, выводим это число в новой строке. Ниже приведён код на Python 3:

a, b = map(int, input().split())

for number in range(a, b + 1):

   digits = set(int(digit) for digit in str(number))

   if all(d != 0 and number % d == 0 for d in digits):

       print(number)

(148k баллов)