Написать программу для расчёта формулы. (Visual Studio , c#)

0 голосов
145 просмотров

Написать программу для расчёта формулы. (Visual Studio , c#)


image

Информатика (466 баллов) | 145 просмотров
Дан 1 ответ
0 голосов

using System;

using System.Linq;

namespace Task29718822

{

   internal class Program

   {

       private static void Main(string[] args)

       {

           Console.WriteLine("Enter n and m:");

           int n = int.Parse(Console.ReadLine()), m = int.Parse(Console.ReadLine());

           Console.WriteLine(Enumerable.Range(n - (m - 1), m).Aggregate(1, (x, y) => x * y));

       }

   }

}

(400 баллов)
0

Можете ли мне объяснить принцип работы программы? Пользователь присваивает целое число переменным "n" и "m", После этого программа должна выполнить некоторые действия. А конкретно, что она делает?

0

Да, конечно.Enumerable.Range(int start, int count) выдаёт IEnumerable, содержащий числа начиная с числа start и в количестве count.

0

Задача сводится к тому что тебе нужно перемножить числа от n до n - (m - 1).Enumerable.Range(n - (m - 1), m) выдаёт тебе как раз ряд, состоящий из этих чисел.После чего Aggregate(1, (x, y) => x * y) просто перемножает все эти числа между собой одно за другим. Результат выводится на экран.ъ

0

Спасибо за объяснения, но вот ещё один вопросик у меня к вам. Почему Enumerable.Range(n-(m-1),m), а не Enumerable.Range(n-(m+n),m)