C++ Напишите программу, которая запрашивает пять целых чисел и выводит в первой строке...

0 голосов
169 просмотров

C++ Напишите программу, которая запрашивает пять целых чисел и выводит в первой строке сумму первых двух чисел, во второй строке -- сумму первых трёх чисел, в третьей строке -- сумму первых четырёх чисел, в четвёртой строке -- сумму всех пяти чисел. Заранее спасибо!


Информатика (162 баллов) | 169 просмотров
Дан 1 ответ
0 голосов

#include

#include

#include

#include

#include

int main()

{

   std::array arr;

   std::generate(arr.begin(), arr.end(), []()

   {

       return 1 + std::rand() % 100;

   });

   std::copy(arr.begin(), arr.end(),

       std::ostream_iterator(std::cout, " "));


   std::cout << std::endl << std::accumulate(arr.begin(), arr.end()-3, 0) << std::endl;</p>

   std::cout << std::accumulate(arr.begin(), arr.end()-2, 0) << std::endl;</p>

   std::cout << std::accumulate(arr.begin(), arr.end()-1, 0) << std::endl;</p>

   std::cout << std::accumulate(arr.begin(), arr.end(), 0) << std::endl;</p>

}


image
(4.0k баллов)
0

Благодарю!