Напишите программу в C Напишите программу, которая считывает значения двух переменных a и...

0 голосов
81 просмотров

Напишите программу в C Напишите программу, которая считывает значения двух переменных a и b, затем меняет их значения местами (в переменной a должно быть записано то, что раньше хранилось в b, и наоборот) Решением задачи не является такой вид: ввод (a) ввод (b) вывод (b, a) Вводится два целых числа


Информатика (267 баллов) | 81 просмотров
Дан 1 ответ
0 голосов

#include

void swap(float& a, float&b)

{

float tmp = a;

b = a;

a = tmp;

}

int main()

{

float a, b;

scanf_s("%f%f", &a, &b);

printf("%f %f", a, b);

swap(a, b);

printf("%f %f", a, b);

return 0;

}

(4.0k баллов)