35 баллов Информатика Срочно нужна помощью Помогите написать программы по уравнениях и...

0 голосов
28 просмотров

35 баллов Информатика Срочно нужна помощью Помогите написать программы по уравнениях и условияю (вычислить число и месяц в невисокосном году по номеру дня) это первая задача Уравнения и задания к ним ниже на фото Вариант везде 19 Порядок фото (1,2,4,3,5,6)


image

Информатика (17 баллов) | 28 просмотров
0

язык тоже не указан, лично я предпочитаю руби, пойдет?

0

Желательно Делфи

0

Или Паскаль

0

Во второй задаче нужно по уравнению составить программу

0

Желательно для Делфи.... язык Паскаль

0

по уравнению составить программу это просто подставить значение икс которое вводят с клавиатуры и вывести значение функции в этой точке или как?

0

и там не уравнение а функция

0

Я могу вас Ловать в соц сети и скинуть полностью весь материал

0

Добавить в соц сети

0

фейсбук или телеграм?

Дан 1 ответ
0 голосов
Правильный ответ

var

   months: array[1..12] of string[15];

   durations: array[1..12]of integer;

   i, d: integer;

begin

   months[1] := 'январь';durations[1] := 31;

   months[2] := 'февраль';durations[2] := 28;

   months[3] := 'март';durations[3] := 31;

   months[4] := 'апрель';durations[4] := 30;

   months[5] := 'май';durations[5] := 31;

   months[6] := 'июнь';durations[6] := 30;

   months[7] := 'июль';durations[7] := 31;

   months[8] := 'август';durations[8] := 31;

   months[9] := 'сентябрь';durations[9] := 30;

   months[10] := 'октябрь';durations[10] := 31;

   months[11] := 'ноябрь';durations[11] := 30;

   months[12] := 'декабрь';durations[12] := 31;

   

   write('Введите день года >> ');

   readln(d);

   d := d mod 365;

   

   for i := 1 to 12 do  

       if d

           writeln(months[i], ' ', d);

           break;

       end

       else  

           d := d - durations[i];

end.


2)

const

   x0 = 0;

   xn = 3;

   n = 100;

var

   x, dx, s: real;

begin

   x := x0;

   dx := (xn - x0) / n;

   s := 0;

   

   repeat

       s := s + x * x + sin(x);

       x := x + dx;

   until x >= xn;

   

   writeln('S = ', s * dx);

end.


(55.0k баллов)
0

Самый лучший ответ Большое спасибо