Дан массив из 10 целых чисел от -20 до 20.Написать программу,определяющая каких элементов...

0 голосов
27 просмотров

Дан массив из 10 целых чисел от -20 до 20.
Написать программу,определяющая каких элементов в нем больше : положительных или отрицательных.

помогите решить,паскаль


Информатика (53 баллов) | 27 просмотров
Дан 1 ответ
0 голосов

Program z10;
var a,b:Array [1..10] of integer;
i,q,k:integer;
Begin
Randomize;
q:=0;k:=0;
For i:=1 to 10 do
begin
a[i]:=random(40)-20;
if(a[i]<0)then q:=q+1;<br>if(a[i]>0)then k:=k+1;
end;
if(k>q)then writeln('положительных больше');
if(kif(k=q)then writeln('положительных и отрицательных одинак.. кол-во');
end.

(6.6k баллов)
0

понятно?

0

не очень) мне на 9 класс надо. при выводе в паскале такое пишут: положительных больше
отрицательных больше

0

а надо найти,каких элементов больше

0

ну так и есть

0

что конкретно непонятно?

0

оно выводит на экран только слова: положительных больше
отрицательных больше
и все,а там нужно конкретно,вроде..

0

обнови страницу скапируй решение заново

0

Program z10;
var a,b:Array [1..10] of integer;
i,q,k:integer;
Begin
Randomize;
q:=0;k:=0;
For i:=1 to 10 do
begin
a[i]:=random(40)-20;
if(a[i]<0)then q:=q+1;<br>if(a[i]>0)then k:=k+1;
write(a[i],' ');
end;
writeln;
if(k>q)then writeln('ïîëîæèòåëüíûõ áîëüøå');
if(kif(k=q)then writeln('ïîëîæèòåëüíûõ è îòðèöàòåëüíûõ îäèíàê.. êîë-âî');
end.

0

да,спасибо большое!!

0

ну тогда удачи!