PascalABC.NET Текстовый файл Input.txt содержит натуральные числа. Написать программу,...

0 голосов
58 просмотров

PascalABC.NET Текстовый файл Input.txt содержит натуральные числа. Написать программу, которая создает текстовый файл Output.txt, содержащий все четные числа файла Input.txt в порядке возрастания.


Информатика (12 баллов) | 58 просмотров
Дан 1 ответ
0 голосов

Попробуй этот код

uses crt;

var f,g:text;

   a,max,min:integer;

begin

assign(f,'C:\in.txt');

assign(g,'C:\out.txt');

reset(f);

rewrite(g);

max:=0;

min:=0;

reset(f);

while not eof(f) do

     begin

     read(f,a);

     if a>max then max:=a;

     if a

     end;

writeln(g,'max ',max);

writeln(g,'min ',min);

close(f);

close(g);

end.

(42 баллов)
0

пример Input.txt ()

0

пример Input.txt (2;1;7;3;-1;8) Output.txt (2;8)