Составить программу ** с#

0 голосов
7 просмотров

Составить программу на с#


image

Информатика (25 баллов) | 7 просмотров
Дан 1 ответ
0 голосов

Using System;
using static System.Math;

public class Test
{
public static double F(double x, double a){
return Math.Sqrt(x + Math.Pow(x + Math.Sqrt(a*Math.Log(x)),1/3.0)) + Math.Sqrt(x)*Math.Sin(Math.Pow(x,-0.5))/(x + Math.Pow(Math.E,a*x));
}
public static void Main()
{
double X = 3.89, A = 4.01;
Console.WriteLine(F(X,A));
}
}

(6.9k баллов)
0

извините мне понятно почему 1/3, но не понятно почему стоит о? объясните пожалуйста

0

3 - лииерал int, а 3.0 - double.

0

литерал*

0

1/3 = 0 (целочисленное деление(

0

1/3.0 = 0.333333...

0

благодарю