Помогите написать программу Pascal.

0 голосов
31 просмотров

Помогите написать программу Pascal.


image

Информатика (40 баллов) | 31 просмотров
Дан 1 ответ
0 голосов

begin

 var mu, w, g, z0, a, b, h, d: real;

 var j: integer;

 Writeln('mu, g, z0, a, b, h, d, j:');

 Read(mu, g, z0, a, b, h, d, j);

 case j of

   1: w := b * h;

   2: w := Pi / 4 * d * d;

   3, 4: w := h / 2 * (a + b);

 else  

 end;

 var Q := mu * w * Sqrt(2 * g * z0);

 Write('Q = ', Q)

end.

(2.5k баллов)