Помогите написать программу Pascal

0 голосов
28 просмотров

Помогите написать программу Pascal


image

Информатика (40 баллов) | 28 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

begin

 var s := ReadReal('s =');

 var Cv: real;

 var (n1, nk, dn) := (100, 10, -5);

 foreach var n in Range(n1, nk, dn) do

 begin

   if n >= 30 then Cv := Sqrt(s / n)

   else if n < 2 then Cv := Sqrt(s / (n - 1))

   else Cv := 0;

   Writeln(n:3, ' ', Cv:0:5)

 end;

end.

(2.5k баллов)
0

PascalABC.NET#