1) Напишите программу, которая вводит трехзначное число и разбивает его ** цифры. Пример:...

0 голосов
99 просмотров

1) Напишите программу, которая вводит трехзначное число и разбивает его на цифры. Пример: при вводе числа 123 программа должна вывести "1, 2, 3" 2) Нужно написать такую же программу как и в первом номере,только для случайных чисел( не для трехзначного числа) Помогите пожалуйста Заранее огромнейшее спасибо


Информатика (519 баллов) | 99 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

универсальный вариант. Долго над решением думать не хотелось, так что ответ такой.  Поскольку ограничений на решение не было)


//PascalABC.NET версия 3.4.0.1677 от 17.06.18

//Если программа не запускается, то обновите версию


var

   n: integer;

   s: string;

begin

   readln(n);  

   s := '';

   while n > 0 do

   begin

       s := (n mod 10).ToString() + '0

       ' + s;

       n := n div 10;

   end;

   

   writeln(s);

end.

(55.0k баллов)
0

в 9 классе строки не изучают , не думаю что учитель зачтет такое

0

запрета на использование строк не было