Написать программу подсчитывающую кол-во чётных и нечётных цифр в числе.

0 голосов
35 просмотров

Написать программу подсчитывающую кол-во чётных и нечётных цифр в числе.


Информатика (22 баллов) | 35 просмотров
0

// PascalABC.NET 3.4.2, сборка 1837 от 11.10.2018begin var s := ReadInteger.ToString; var k := s.Where(c -> '02468'.Contains(c)).Count; Println('Четных', k, 'нечетных', s.Length - k);end.

Дан 1 ответ
0 голосов
Правильный ответ

Форматированный код на C#  и демонстрация работы на скриншотах.

Код текстом ниже.

using System;

using System.Linq;

namespace task29989793

{

   class Program

   {

       static void Main()

       {

           Console.Write("Enter number: ");

           var number = Console.ReadLine().Select(i => int.Parse(i.ToString()));

           Console.WriteLine($"Count of odd digits: {number.Count(i => i % 2 == 1)}");

           Console.WriteLine($"Count of even digits: {number.Count(i => i % 2 == 0)}");

       }

   }

}


image
image
(400 баллов)
0

Извините, но мне нужен Паскаль

0

¯\_(ツ)_/¯