Нужно в паскале написать программу с одномерным массивом из десяти элементов, чтоб она...

0 голосов
75 просмотров

Нужно в паскале написать программу с одномерным массивом из десяти элементов, чтоб она находила количество чётных, нечётных и среднее арифметическое. Это всё в одной программе.


Информатика (84 баллов) | 75 просмотров
0

Среднее арифм. скорее всего количества четных и нечетных

Дан 1 ответ
0 голосов

var a:array [1..10] of integer;

i,k1,k2,s1,s2:integer;

begin

for i:= 1 to 10 do

a[i]:= Random(100);

writeln(a);

for i:=1 to 10 do

begin

if a[i] mod 2 = 0 then

begin

k1:=k1+1;

s1:=s1+a[i]

end

else

begin

k2:=k2+1;

s2:=s2+a[i]

end

end;

writeln('Количество чётных элементов: ',k1);

writeln('Количество не чётных элементов: ',k2);

writeln('Cреднее арифметическое чётных элементов: ',s1/k1);

writeln('Cреднее арифметическое не чётных элементов: ',s2/k2);

end.

(3.9k баллов)
0

Спасибо, а есть ли возможность написать не через рандом?

0

Вместо for i:= 1 to 10 doa[i]:= Random(100); пишем writeln ('Введите 10 элементов массива через пробел.Потом нажмите Enter.');for i:=1 to 10 do read(a[i]);

0

Спасибо большое!