Мне нужна помощь: В Фрее паскаль Рассмотрим массив T [1..n] целых чисел, где n

0 голосов
71 просмотров

Мне нужна помощь: В Фрее паскаль Рассмотрим массив T [1..n] целых чисел, где n <= 20. Напишите программу, используя процедуру, которая будет отображать положительные элементы этого массива.Мне нужно под этот модель :этот програм считает сумму. type tab=array[1..10] of integer; var a:tab; i,n:integer; s:real; procedure suma(var x:tab; n:integer; var sum:real); var i:integer; begin sum:=0; for i:=1 to n do sum:=sum+x[i]; end; begin{main} write('n='); readln(n); write('dati elementele tabloului:'); for i:=1 to n do readln(a[i]); suma(a,n,s); write('s=',s:7:2); end. Спасибо заранее.


Информатика (53 баллов) | 71 просмотров
0

Такой же идиотизм - объявить глобальную i, а в процедуре объявить и использовать еще локальную. Короче, все ясно с уровнем этого "преподавателя".

0

особенно порадовала фраза "dati elementele tabloului" - это молдавское "дать элементы изображения". Какого изображения?

0

Я из Молдавии

0

Выводить простите

0

А что значит отображать элементы? Куда их отображать? Может выводить?

0

насчет глобальной i, интересно, что в pascalABC.NET так не работает, нужно объявлять свою локальную в подпрограмме или описывать в заголовке цикла, а в фрипаскале достаточно глобальной, хм

0

Может будет правильно

0

Реши как ты знаешь

0

iolandavalerypad353 помоги пожалуйста

0

"что в pascalABC.NET так не работает" - все там работает, как положено в современном языке. Нельзя использовать глобальную переменную в качестве параметра цикла внутри процедуры? Да, нельзя, это не дает оптимизировать код.

Дан 1 ответ
0 голосов

Ну как-то так, в фрипаскале работает


image
(2.5k баллов)
0

Спасибо большое

0

Там ведь тоже есть консольные штучки.

0

Нет, просто он не требует ДОС-среды, как FPC

0

в школах

0

в Lazarus формошлепством занимаются, я так думаю

0

Интересно преимущественное распределение "паскалей" по странам. Россия, Беларусь - PascalABC.NET, Украина, Казахстан - Lazarus, Молодова - Free Pascal.

0

могу, наверное, но не хочу, это уж вы сами как-нибудь накалякайте чего-нибудь =)

0

А блок-схема сможете делать

0

привет